首页
产品
CLup:PostgreSQL高可用集群平台CData高性能数据库云一体机CBackup数据库备份恢复云平台CPDA高性能双子星数据库机
解决方案
数据库专业技术服务全栈式PostgreSQL解决方案Oracle分布式存储化数据库云
文章
客户及伙伴
中启开源
关于我们
公司简介 联系我们
中启开源
往前插入
往后插入
删除

安装要求

1. 硬件平台要求

CLUP管理模块需要安装到一台独立的机器上,对此机器的配置不需要很高,具体需求如下:

2. 软件依赖

CLUP管理机器以及clup-agent部署的数据库库主机上需要安装以下依赖包:

  1. yum install -y tcl tcl-devel tk

clup-agent机器上需要安装ipmitool工具、arping包以及psmisc.x86_64包,clup-agent需要使用ipmitool中的ipmitool命令和arping包中的arping命令来以及psmisc.x86_64包中的fuser命令。

如果在CentOS或Redhat等操作系统下,安装命令如下:

  1. yum install ipmitool.x86_64
  2. yum install psmisc

clup-server和clup-agent模块都需要运行在操作系统的root用户下。

3. 数据库版本

CLUP目前支持PostgreSQL9.5以上的版本,不支持PostgreSQL9.5以下的版本。

数据库软件中需要安装pg_stat_statements插件。